Excelde En Çok Kullanılan Formüllerin Fonksiyonları Ve Açıklamaları


















İş hayatının vazgeçilmezlerinden Excel'de birçok formül biliyorsunuz ama işinizi daha da kolaylaştıracak en çok kullanılan tüm excel formüllerini bu yazımda derledim. Elinizin altında bulunsun. Faydalı olması dileğiyle.

1. AŞAĞI YUVARLAMA

=aşağıyuvarla(C7;2)
Formüldeki 2 rakamı, ondalık basamak sayısını ifade eder. Örnek: 150,999 ise 150,99 olarak yazar.

2. YUKARI YUVARLAMA

=yukarıyuvarla(C7;2)
Formüldeki 2 rakamı, ondalık basamak sayısını ifade eder. Örnek: 13,551 ise 13,56 olarak yazar.

3. YUVARLAMA

=yuvarla(C7;2)
Formüldeki 2 rakamı, ondalık basamak sayısını ifade eder. Örnek: 13,551 ise 13,56 olarak yazar. 13,555 ise 13,56 olarak yazar.

4. TAVANA YUVARLAMA

=tavanayuvarla(C7;5)
c7 hücresindeki sayıyı, 5 tam sayısı yada katlarına yuvarlar.  Örnek: Değer  1,25 ise 5  olarak yazar. 8,00 ise 10 olarak yazar.

5. TABANA YUVARLAMA

=TABANAYUVARLA(E2;5)
Aşağıya doğru 0, 5 yada katlarına yuvarlar.  Örnek: 1,25 ise 0  olarak yazar. Değer 8,00 ise 5 olarak yazar. Formüldeki 5 rakamı 10 olsaydı aşağıya doğru 10 rakamının katlarına yuvarlayacaktı.

6. YUVARLAMA

=NSAT(E5;E7)
Bir sayının ondalık kısmını istenilen düzeyde kaldırarak tamsayıya yuvarlar. Örnek: e5 10,55555 ise,     e7 ondalık basamak sayısı olup 2 olursa sonuç olarak  10,55 yazar.

7. TAMSAYI

=TAMSAYI(D3)
Tüm kesirleri atarak tam sayı kısmını rakam olarak yazar.

8. ÇARPMA

=çarpım(c2;d2;e2)
Hücrelerdeki  sayıları çarpar.

9. ÇİFT

=çift(E2)
Üst ilk çift sayıya yuvarlar. Örnek 1,2 ise 2 olarak yazar.

10. TEK

=TEK(E2)
En yakın üst tek tamsayıya  yuvarlar. Örnek 1,2 ise 3 olarak yazar.

11. ETOPLA (ŞARTA BAĞLI TOPLAMA)

=ETOPLA(D2:D5;">0")
D2 ila D3 arasındaki değerlerden yalnızca sıfır rakamından büyük olanları toplar.

12. ETOPLA (ŞARTA BAĞLI TOPLAMA)

=ETOPLA(D2:D5;"<0")
D2 ila D3 arasındaki değerlerden yalnızca sıfır rakamındanküçük olanları toplar.

13. ETOPLA (ŞARTA BAĞLI TOPLAMA)

=ETOPLA(D2:D6;"=10")
D2 ila D3 arasındaki değerlerden yalnızca 10 rakamına eşit olanları  toplar.

14. ETOPLA (ŞARTA BAĞLI TOPLAMA)

=ETOPLA(D2:D6;"=10")
D2 ila D3 arasındaki değerlerden yalnızca 10 rakamına eşit olanları  toplar.

15. ETOPLA (ŞARTA BAĞLI TOPLAMA)

=ETOPLA(B20:B100;E1;E20:E100)
e1 hücresindeki değeri, b20 ila b100 arasındaki dolu hücrelerin içerisinde bulur.  Satır hizasındaki e20 ila e100 arasında isabet eden hücrelerdeki sayı değerlerini toplar.

16. KAREKÖK

=KAREKÖK(D2)
D2 hücresindeki sayının karekökünü bulur.

17. Pİ SAYISI

=pi()
Pi sayısını verir.

18. ROMEN RAKAMLARI

=ROMEN(c3)
c3 hücresindeki rakamı, romen rakamına çevirir. Örnek: c3 hücresindeki rakam 50 ise L olarak yazar.

19. SAYI ÜRETME

=S_SAYI_ÜRET()
Her kliklemede farklı sayı üretir.

20. YİNELE

=YİNELE("ALİ";100)
Çift tırnak içerisine yazılan değeri istenen sayı kadar yineleyerek yazar. Örnekte ALİ adını yüz defa yanyana yazar.

21. EN ÇOK OLAN

=ENÇOK_OLAN(A2:A20)
a2 ila a20 hücrelerinde en çok yinelenen değeri yazar.

22. GEOMETRİK ORTALAMA

=GEOORT(F20:F24)
Dolu hücrelerdeki pozitif rakamları toplar. Pozitif Dolu hücre sayısına böler. Sıfır ve eksi değerdeki sayılar varsa işlem yapmaz. Boş hücreleri dikkate almaz.

23. ORTALAMA

=ORTALAMA(A2:A20)
Dolu hücrelerdeki rakamları toplar. Dolu hücre sayısına böler. Sıfır rakamı ile negatif sayıları dikkate alır. Boş hücreleri dikkate almaz.

24. EN BÜYÜK SAYIYI BULMA

=MAK(E23:G25)
e23 ila g25 arasındaki en büyük sayıyı bulur ve yazar.

25. EN KÜÇÜK SAYIYI BULMA

=min(E23:G25)
e23 ila g25 arasındaki en küçük sayıyı bulur ve yazar.

26. YAZIM DÜZENİ

=YAZIM.DÜZENİ(d20)
ALİ BİZE GELDİ.  yi Ali Bize Geldi. Şeklinde yazar.

27. BÜYÜKHARF

=BÜYÜKHARF(D1)
D1 hücresindeki metni büyük harflerle yazar.

28. KÜÇÜK HARF

=KÜÇÜKHARF(B19)
Büyük alfabe harfleriyle yazılmış metni  küçük alfabe harflerine çevirir.

29. ARA

=ARA(C2;D2:D6;E2:E6)
c2 hücresi içerisindeki yazılan değeri, d sütununda d2:d6 arasındaki hücrelerde arar. Bulursa e sütununda e2:e6 arasında karşılık gelen satırdaki değeri bulur ve yazar. Değer yoksa/boşsa  #YOK yazar.

30. DÜŞEY ARA

=DÜŞEYARA(A4;B5:F100;3;YANLIŞ)
a4 hücresi içerisindeki yazılan değeri, b sütununda b5:b100 arasındaki hücrelerde yukarıdan aşağıya doğru arar. Bulursa b sütununda itibaren üçüncü sütun olan d sütununda  d5:d100 arasında karşılık gelen satırdaki değeri bulur ve yazar. Değer yoksa/boşsa  #YOK yazar.

31. DÜŞEY ARA

=DÜŞEYARA(E1;B5:F100;3;0)
e1 hücresi içerisindeki yazılan değeri, b sütununda b5:b100 arasındaki hücrelerde yukarıdan aşağıya doğru arar. Bulursa b sütununda itibaren üçüncü sütun olan d sütununda  d5:d100 arasında karşılık gelen satırdaki değeri bulur ve yazar. Değer yoksa/boşsa  0 yazar.

32. YATAY ARA

=YATAYARA(B3;B4:D13;6;YANLIŞ)
b3 hücresinde yazan değeri, b4:d4 arasındaki yatay hücrelerde arar. Bulduğunda bu hücre bir olmak şartıyla hücreden aşağıya doğru altıncı hücredeki değeri bulur ve yazar.  Değer yoksa/boşsa  #YOK yazar.

33. MOD

=MOD(E5;F5)
Bir sayının diğer bir sayıya bölünmesi sonucu kalanı verir. Formülde e5 bölünen, f5 bölendir. Örnek: 10 rakamının 3 rakamına bölünmesinde kalan 1 dir.

34. HAFTANIN GÜNÜ

=HAFTANINGÜNÜ(E27;2)
Formüldeki e27 tarihi ifade eder. 2 ise haftanın Pazartesi günü ile başladığını ifade etmektedir. 1olsaydı haftanın Pazar günü başladığını ifade edecekti. Bu duruma göre formül sonucunda 1 yazarsa gün Pazartesi, 2 yazarsa Salı anlamına gelir…

35. BUGÜNÜN TARİHİNİ YAZDIRMA

=bugün()
Bu günün tarihini 10.05.2013 şeklinde tarih formatlı olarak yazar.

36. ŞİMDİ

=ŞİMDİ()
Tarih, saat ve dakikayı yazar. Örnek: 13.05.2013 12:02   gibi

37. HAFTANIN GÜNÜNÜ YAZDIRMA

=METNEÇEVİR(HAFTANINGÜNÜ(E35);"gggg")
e35 hücreside bulunan tarih hangi güne aitse o günü yazar. Örnek: e35 hücresinde 13.05.2013 tarihi yazıyorsa Pazartesi şeklinde yazacaktır.

38. HAFTANIN GÜNÜNÜ YAZDIRMA

=METNEÇEVİR(ŞİMDİ();"gggg")
Bugün hangi gün olduğunu yazar. Örnek, bugün Pazar ise Pazar şeklinde yazacaktır.

39. AY ADINI  YAZDIRMA

=METNEÇEVİR(ŞİMDİ();"aaaa")
Bu ay  hangi ay olduğunu yazar. Örnek, bu ay Mayıs ise Mayıs şeklinde yazacaktır.

40. DADİKA

=DAKİKA(E29)
e29 hücresindeki saatin dakikasını yazar. Örnek: saat 12:17 ise 17 olarak yazar.

41. SAAT

=SAAT(E30)
e30 hücresindeki saatin saat kısmını yazar. Örnek Saat 12:17 ise 12 olarak yazar.

42. SANİYE

=SANİYE(E31)
e31 hücresindeki saatin saniyesini  yazar.

43. EN ÇOK OLAN(TEKRARLANAN) DEĞERİ BULMA

=ençok_olan(F38:H49)
f38 den h49 arasında en çok yinelenen değeri verir.

44. BOŞLUK SAYISINI BULMA

=BOŞLUKSAY(F38:H49)
f38 den h49 arasındaki hücrelerden kaç tanesinin boş olduğunu sayar.

45. RAKAM OLAN HÜCRE SAYISI

=EĞERSAY(F38:H49;">0")
f38 den h49 arasındaki hücrelerden kaç tanesinde sıfırdan büyük sayı olduğunu bulur.

46. BELLİ DEĞERİN SAYISINI BULMA

=EĞERSAY(F38:H49;"KALEM")
f38 den h49 arasındaki hücrelerden kaç tanesinde KALEM yazısı olduğunu bulur.

47. BELLİ DEĞERİN SAYISINI BULMA

=EĞERSAY(F38:H49;4)
f38 den h49 arasındaki hücrelerden kaç tanesinde 4 rakamı olduğunu bulur.

48. BELLİ DEĞERİN SAYISINI BULMA

=EĞERSAY(F38:H49;F37)
f38 den h49 arasındaki hücrelerden kaç tanesinde, f37 hücresindeki değer olduğunu bulur.

49. RAKAMLI DOLU  HÜCRE SAYISI

=BAĞ_DEĞ_SAY(F39:F44)
f39 ila f44 arasındaki rakam olan dolu hücre sayısını bulur.

50. DOLU  HÜCRE SAYISI (RAKAM YADA YAZI)

=BAĞ_DEĞ_DOLU_SAY(F44:F50)
f44 ila f50 arasındaki rakam yada metin olsun dolu tüm hücrelerin sayısını bulur.

51. SÜTUN SAYISI

=SÜTUNSAY(A1:H1)
a1 ila h1 arasında kaç sütün varsa sayar. Formül =SÜTUNSAY(A:H) şeklinde de yazılabilir.

52. SATIR SAYISI

=SATIRSAY(A5:A55)
a5 ila A55 arasında kaç satır varsa sayar. 

53. TARİHİ METNE ÇEVİRME

=METNEÇEVİR(BUGÜN();"GG/AA/YYYY")
Bugünkü tarihi istenen formatta metne çevirir. Metne çevrilen tarih, özellikle formülle birleştirme işlemlerinde kullanılır. Hata vermez. Tarihimiz 13/05/2013 şekline gelecektir.

54. TARİHİ METNE ÇEVİRME

=METNEÇEVİR(E44;"GG/AA/YYYY")
e44 hücresindeki tarihi  metin formatına çevirir. Örnek: 14.05.2013 şeklindeki tarih formatı, 14/05/2013 şeklinde metne çevrilmiş olur.

55. PARAF İÇİN TARİH YAZDIRMA (GÜNSÜZ)

=BİRLEŞTİR("…./";METNEÇEVİR(BUGÜN();"aa/yyyy"))
Bu formülle tarihin gün kısmı ….. şeklinde olup, ay ve yıl kısmı otomatik yazılacaktır. Örnek:  ……/05/2013  gibi

56. SAĞDAN PARÇA ALMA

=SAĞDAN(B45;3)
b45 hücresinde yazan değerin sağdan 3 tanesini al demektir. Örnek:  b45 hücresinde AHMET yazılı olsa buraya MET yazacaktır.

57. SOLDAN PARÇA ALMA

=SOLDAN(B45;3)
b45 hücresinde yazan yazının soldan 3 tanesini al demektir. Örnek: b45 hücresinde AHMET yazılı olsa buraya AHM yazacaktır.

58. PARÇA ALMA (SOLDAN)

=PARÇAAL(E49;1;4)
e49 hücresinde yazan yazının soldan birinci elemanından itibaren dört adet harfi al anlamına gelir. Örnek: e49 hücresinin içerisinde DENİZLİ yazıyorsa  DENİ yazacaktır. Formül; =PARÇAAL(E49;2;4) şeklinde olsaydı ENİZ yazacaktı.

59. İŞLEMLERDE ÖNCELİK SIRASI

1-Parantez()  2-Yüzde  3-Kuvvet(Üs)  4-Çarpma ve Bölme  5-Toplama ve Çıkarma

60. SAYIYI METNE ÇEVİRME

=METNEÇEVİR(E55;"0.0,00")
e55 hücresindeki sayıyı metne çevirir. Birleştirme formülü uygulamalarında sağdaki sıfır değerleri sayı formatında iken ortadan kalkmaktadır. Örnek: 25,40 sayısı 25,4 olmaktadır. Metne çevirip birleştirme formülünde kullanırsak 25,40 metin formatlı sayı değişmemektedir.

61. HERHANGİ BİR HÜCREDEKİ FORMÜLÜ BULMA

=FORMUL(E60)
Aşağıdaki makro ile bir hücredeki formulu bulabiliriz. Aşağıdaki makroyu VBA Projektte modül içerisine yazıp makroları etkinleştirmeniz gerekir. Formüldeki e60, formülü aranan hücredir.
Function formul(InputCell As Range) As String
    formul = InputCell.FormulaLocal
End Function

62. TOPLAMA

=TOPLA(A2:A10)
A2′den A10′a kadar olan tüm hücrelerin değerlerini toplar.

63. TOPLAMA

=100+455+222
3 adet sabit sayıyı toplar.

64. TOPLAMA

=F14+650
F14 hücresindeki sayı ile sabit bir sayıyı  toplar.

65. TOPLAMA

=A5+B3+F4
3 Adet hücrenin içerisindeki sayıları toplar.

66. ÇARPMA

=35*45
2 Sabit rakamı çarpar.

67. ÇARPMA

=A2*87
A2 hücresi ile bir sabit rakamı çarpar.

68. ÇARPMA

=E7*B7
EF Hücresi ile B7 hücresindeki sayıları çarpar.

69. ÇIKARMA

=200-25
İki sabit rakamın farkını alır

70. ÇIKARMA

=44-B4
44 Sabit sayısından B4 hücresindeki sayıyı çıkarır.

71. ÇIKARMA

=A2-C2
2 hücrenin farkını alır.

72. BÖLME

=225/15
Bir sabit rakamı bir başka sabit rakama böler.

73. BÖLME

=A20/55
A20 hücresinin içeriğini bir sabit rakama böler.

74. BÖLME

=A10/C10
A10 hücresindeki sayıyı C10 hücresindeki sayıya böler.

75. DÖRT İŞLEM KOMUTU ( TOPLA)

=TOPLA(F75*G75-H75)
TOPLA, dört işlem komutu olarak dikkate alır. İşlem sırasını takip eder. İşlem sırasında çarpma önce geldiğinden f75 ile g75 hücresindeki sayıyı çarpar. Sonra h 75 hücresindeki sayıyı çıkarır.
Not; Formül  =TOPLA(F75;F80) olursa yalnız f75 ve f80 hücresindeki sayıları toplar.
Formül =TOPLA(F75:F80) olursa bu durumda f75 ila f80 arasındaki tüm hücrelerdeki sayıları toplar.

76. DÖRT İŞLEM KOMUTU ( ÇARPIM)

=ÇARPIM(F75+G75/H75)
ÇARPIM, dört işlem komutu olarak dikkate alır. İşlem sırasını takip eder. İşlem sırasında bölme önce geldiğinden g75 i  h75 hücresindeki sayıya böler. Sonra  f 75 hücresindeki sayıyla toplar.

77. BİRLEŞTİRME

=BİRLEŞTİR(A25;" ";F25)
A25 hücresindeki değer ile F25 hücresindeki metni birleştirir. Arasına bir karakter boşluk koyar. Boşluk çift tırnak içinde gösterilmelidir.

78. BİRLEŞTİRME

=BİRLEŞTİR(A25;" ";"GEÇTİ.")
A25 hücresindeki değer ile GEÇTİ  metni birleştirir. Arasına bir karakter boşluk koyar. Boşluk çift tırnak içinde gösterilmelidir. Birleştirilecek değerler de çift tırnak içinde gösterilmelidir.

79. UZUNLUK

=UZUNLUK(A8)
A8 hücresindeki metnin kaç karakterden oluştuğunu bulur.

80. EĞER

=EĞER(A3>2;"İYİ";"KÖTÜ")
A3 hücresindeki sayı 2 den büyükse İYİ değilse KÖTÜ yazar.

81. EĞER

=EĞER(A3>=2;"İYİ";"KÖTÜ")
A3 hücresindeki sayı 2 rakamı dahil ve 2 den büyükse İYİ değilse KÖTÜ yazar.

82. EĞER

=EĞER(B2>0;"KÂR";"ZARAR")
B2 hücresinin değeri 0′dan büyükse KÂR değilse ZARAR yazar.

83. EĞER

=EĞER(B2>2;"GEÇTİ";"KALDI")
B2 hücresinin değeri 2′den büyükse GEÇTİ değilse KALDI yazar

84. EĞER NOT FORMÜLÜ

=EĞER(A2>89;"A";EĞER(A2>79;"B";EĞER(A2>69;"C";EĞER(A2>59;"D";"F"))))
A2 hücresi öğrencinin aldığı puanın yazıldığı hücreyi temsil etmektedir. Burada öğrenci 89 dan büyük puan alırsa A, 79 dan büyük puan alırsa B, 69 dan büyük puan alırsa C, 59 dan büyük puan alırsa D, 59 ve daha düşük  puan alırsa E notu almış olmaktadır

Post a Comment

Daha yeni Daha eski